npm安装依赖至指定版本的方法
本文最后更新于 256 天前,其中的信息可能已经有所发展或是发生改变。

简介

本文介绍npm安装依赖至指定版本的方法。依赖的版本可以在淘宝镜像官方查询到.

三种方法

方法一

先在package.json里修改好指定版本号,然后输入:

npm update webpack

方法二

npm update webpack@4.7.0

会把webpack更新至指定版本,但是不会写到package.json文件里,如果需要写到package.json里执行如下命令:

npm update webpack@4.7.0 --save

其中--save等于-S.

方法三

npm update webpack@latest -S

--save--save-dev区别

一句话:--save-dev是你开发时依赖的东西,--save是发布后还依赖的东西.

参考

  1. https://segmentfault.com/q/1010000009049039?_ea=1823977
  2. https://segmentfault.com/q/1010000005163089

订阅

内容同步更新在王永杰的网络日志微信小程序

微信搜索“王永杰的网络日志”或者扫描二维码,即可订阅。

标题:npm安装依赖至指定版本的方法
地址:https://xiaodongxier.com/1548.html
作者:王永杰
暂无评论

发送评论 编辑评论


				
|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇